Beiträge von MacArmand

    Hallo, weiß nicht ob ich weiterhelfen kann, aber wie wäre es, wenn du den Objekten eine Variable zuweist, die du in deinem Actor mit der Boxcollision abrufst und wenn sie overlappen +1, wenn sie end overlappen -1.

    Im Levelblueprint oder Gamemode, könntest du mit get all Actors of class alle Objekte abfragen die diese Variable haben und dann entweder getrennt oder gemeinsam ausgeben.


    Hoffe war eine Hilfe, ciao und schönen Abend

    So hab den Fehler gefunden. Falls es jemanden interessiert. Ich benutze als Static Mesh eine Plant aus dem Flowers and Plants Nature Pack. Dort musste ich bei den benutzten Plants die Collision umstellen, damit mein LineTracebychannel den ich nutze diese auch erkennt. Ihr glaubt gar nicht wie froh ich bin das gefunden zu haben.


    Schönen Tag euch allen und viel Erfolg :bye:

    So, funktioniert wieder alles wie vorhin. Aber eine andere Sache die mich juckt. Für das INventorysystem, greife ich auf ein Interface zurück. Schön und gut. Dieses kann von dem eigentlichen Actor auch angenommen werden und das Mesh verschwindet, wie gewollt nach Betätigen der Taste. Jedoch nicht die Child des Actors. Keine Ahnung was ich da machen kann. Hab schon hier und da versucht, will aber nicht. Alle Meshes der Childs sind editable when inherited. Vielleicht hilft das.

    Die Bindings waren richtig eingestellt. Kurz, ca. für eine Sekunde scheinen die gefüllten Progressbars des HUD Widgets auf, auch mit dem richtigen Text, dann alle leer und ich kann mich nicht mehr bewegen. Keine Ahnung an was es liegen könnte, nehme aber an es hat etwas mit dem Interface zu tun, da es das letzte war, dass ich änderte.


    Vielleicht Vorschläge oder Anregungen? Danke im Voraus,

    Danke für die Tipps. Den INput Mode Game Only habe ich nun dahinter gesetzt. An den Bindgings habe ich nichts geändert, seitdem es einst funktioniert hat. Habe nun einmal die Ap gelöscht und wieder hinzugefügt uns siehe die Leiste erscheint, die Zahl nicht. Ich beende einmal UE und versuche neu zu laden, vielleicht gitb es da irgendwelche anderen Probleme.


    Aber danke, dass mit dem INput ist schon sehr hilfreich.

    Schönen Abend Butter Fly Games

    Hallöchen, da melde ich mich mal wieder mit einer vermutlich peinlichen Frage, aber wer nicht fragt stirbt dumm.


    Bisher hat ja alles mit meiner Spielfigur funktioniert. Ich starte das Level mit einem Widget(Mainmenu) und nach aktivieren eines Buttons startet das Spiel, es erschien ein zweites Widget das HUD Widget, mit LP, AP, MP Anzeige und ich konnte meine Firstpersonspielfigur mit WASD bewegen.

    Nun zu meinem Problemchen.


    Ich versuchte mich an einem INventorysystem und habe dazu ein Youtube-Video versucht nachzumachen mit Implementierung eines Interface. Hat am Anfang nicht geklappt, bin auf einige Fehler meinerseits gestoßen, kein INterface (Message) gefunden, da ich das Interface auch in dem Charakter implementiert habe, behoben und dann . . . meine Spielfigur bekommt nach Eingabe des Buttons des Mainmenüs keinen INput mehr, da kann ich drücken bis die Finger bluten. Auch die LP,AP,MP Anzeige die ansonsten in so schönen Farben schillerte, ist nun . . . Leer. Keine Ahnung was ich da falsch gemacht habe. Habe zum Großteil aus Videos nachgemacht. Ich schicke ein paar Screenshots von meinen Blueprints und hoffe ihr könnt mir helfen.


    In jedem Fall einen schönen Tag und alles Gute, euer Marc

    Hallo, auch von mir einen schönen 1.Mai. Alles Gute.


    Hätte da eine Frage: Ich habe in einem Level CharacterActors platziert die mithilfe eines Blackboard und Behaviourtree durch die Gegend laufen und den Spieler attackieren. So weit so gut. Funktioniert echt klasse, nur: Das funktioniert nur, wenn ich unter Window - Levels das entsprechende Level als Current markiere. Sollte ich ein anderes Level als current markieren bleiben die Kreaturen einfach stehen. Teile des Behaviourtrees funktionieren dann, andere Teile nicht. Habe Minimal_Default als Hauptlevel und darunter Level und darunter wieder Level angeordnet. Lade ich das Mainlevel, dann bewegen sich die Character wie will, aber nur die gespawnt wurden, die schon platziert wurden, fehlen. Lade ich das Level in welchem die Character platziert sind, so erscheinen zwar alle aus dem Level, aber die aus den anderen Level fehlen. Sie sind einfach nicht da. Ich nutze world composition, sollte open world werden. Habe unter dem Charactermesh, die Funktion "Placed in world or spawned" aktiviert. Daran liegt es nicht.


    Vielleicht könnt ihr mir ja helfen.

    Auf jeden Fall einen schönen Feiertag und alles Gute,


    Ciao und guten Tag euer Marc

    :thumbup: Das kann gut sein, nur wo finden, wenn keine Ahnung ||


    Naja, im Laufe der Zeit hoffe ich halt doch dann drauf zu kommen. Wird nicht das letzte Spawnobjekt sein, dass ich machen werde, hoffentlich. Aber danke für die Hilfe. Wenn ihr Anregungen habt wo ich suchen könnte, bitte lasst hören. Ich werde demnächst mich wieder auf andere Sachen stürzen und dann mal sehen, wie ich damit umgehen werde. Schönen Tag euch allen und viel Erfolg


    Ciao und schönen Tag, euer Marc :bye:

    Wenn ich diese Funktion auswähle muss wenigstens ein Monster schon im Level platziert sein, ich hätte aber gerne die Möglichkeit in einem Level einmal zusätzliche Monster zu platzieren und in einem anderen Level einmal keine Zusätzlichen zu platzieren.

    Aber danke, werde vermutlich in jedem Level wenigstens eines zusätzlich platzieren und diese Funktion auswählen. stellt sich mir nur die Frage wie dass dann bei einem Savegame funktioniert, wenn ich den alten Speicherstand lade und das zusätzliche Monster schon vernichtet wurde. Aber bis dahin ist es noch ein langer Weg und wer weiß was mir sonst noch bis dahin einfällt.


    Danke, schönes Wochenende, ciao

    Danke für die Lehrstunde :rolleyes:

    Das mit dem Spawnen habe ich eigentlich schon hinbekommen, nur der Behaviourtree der gespawnten Monster wird nur ausgeführt, wenn vorher schon ein Monster sich in dem Level befindet.

    Die Korrektur ist jedenfalls zum Zerkugeln: Da habe ich wohl ein bisschen Mist gebaut, ist aber schon geändert.

    Tja, diese Logik, ein furchtbares Monster, immer so penibel :)


    Auf jeden Fall danke für die Tipps. Ich denke für folgende Anfragen zu dem Thema sehr sinnvoll.

    Bin schon draufgekommen, dass es an Auto Possess Ai liegt. Gebe ich es nur auf Spawned, dann funktioniert das Spawnen, aber nicht wenn ein Monster schon platziert wurde.

    Bei Place in World or Spawned muss vorher schon ein Monster platziert sein, sonst funktioniert es nicht. Da ich mehrere Levels nutze, könnte es sein, dass ich eine Funktion bräuchte, die es mir erlaubt in einem Level einmal nur Spawned und einmal World or Spawned zu nutzen. Denke es wäre auch hilfreicher, wenn bei Place in World or Spawned, nicht extra ein Monster schon platziert sein müsste, aber die Möglichkeit besteht.


    Danke auf jeden Fall für die Hilfe, sonst funktioniert alles einwandfrei.

    Den Fehler warum die Monster nicht gespawnt wurden konnte ich beheben, war ein dummer Branch-Fehler *dead*


    Aber ich verstehe nicht warum die gespawnten Monster nicht den Behaviourtree durchführen. Wenn ich ein Monster schon vorher im level platziere, funktioniert es, ansonsten stehen meine gespawnten nur herum. Keine Ahnung an was das liegt. Tja, dann eben vorher eines platzieren.


    Schönen Abend und alles Gute.


    Ach ja, danke für Zeit und Mühen 8o

    Ai Controller hat er. Was mich so verwundert ist, dass es einmal funktioniert und einmal nicht. Der Charakter spawnt schon, wenigstens einer, manchmal, aber er nutzt nicht den Behaviortree, bis auf einmal. Aber ich werde es versuchen.


    Danke für den Tipp, schönes Wochenende euch allen

    Als Spline Actor sollte es funktionieren. Suche am Besten in Youtube unter Roadspline Tutorial. Denke da ist das Richtige für dich drinnen. Mit dem Blueprint kannst du Punkte benutzen um die Straße in den drei Dimensionen zu bewegen. Damit kommst du acuh auf Hügel. Im Schlimmsten Fall müsstest du nur das Landscape ein wenig anpassen. Habe auch einmal mit einem Landscapetool das hinbekommen. Am Besten youtube durchforsten.


    Externer Inhalt www.youtube.com
    Inhalte von externen Seiten werden ohne Ihre Zustimmung nicht automatisch geladen und angezeigt.
    Durch die Aktivierung der externen Inhalte erklären Sie sich damit einverstanden, dass personenbezogene Daten an Drittplattformen übermittelt werden. Mehr Informationen dazu haben wir in unserer Datenschutzerklärung zur Verfügung gestellt.


    Könnte passen :bye:

    Also ich habe für meine Straße Splines benutzt. Habe dazu ein Tutorial über Youtube angesehen. Das Ergebnis ist zwar nicht perfekt, aber es funktioniert.

    Hier der Link zum Blueprint: Splinestreet > BlueprintUE.com | PasteBin For Unreal Engine 4


    Das gehört ebenfalls dazu:


    Am Besten ein Video zu Splinestreets UNreal engine 4 ansehen. Gibt es jede Menge. Leider finde ich gerade das Video nicht, dass ich mir einst angesehen habe, aber das BP sollte funktionieren. Eignet sich vor allem für kleinere Stücke. Ganze Straßen werden vermutlich ein wenig anders gemacht.


    Viel Erfolg und alles Gute, ciao